I'm designing a loan calculator, which based on the loan you request (separate input not shown on the images), allows you to explore your options of monthly paybacks, and the period during which you pay it back. I decided to represent this on a single slider, and immediately show the corresponding values, whether you know how much you can afford to pay back each month, or you want to explore the timeframe to see what numbers that gives you.
I posted my two designs below, currently we're going with the first one, although I find the second one more meaningful. My question to you is: is it too confusing to combine these two values on one slider, or should we use two for the two input fields, and change them automatically based on each other's value?
Also note that the minimum and maximum values (€386 and €3066) change dynamically based on your loan request in the first step (the step not shown here).