Labels for check-boxes should always be phrased in a positive/active way. As a rule of thumb, consider your alternative without the verbs:
comments in this post
It’s obvious that an empty check-box next to this label means ‘disable’ (or ‘forbid’) and a filled one stands for ‘allow’ (or ‘enable’). You may make it explicit for sure – you may even be required to by the applicable style guide, which will be language-dependent. Note that there are probably more languages that have to paraphrase ‘disable’ as “don’t enable”, because they’re lacking a lexeme for it, than those that need “don’t forbid” for ‘allow’.
So don’t use verbs like these in checkbox labels: hide, deactivate, disable, (turn) off, exit, leave etc.
There are many examples of GUIs that get this wrong. The View menu in Preview.app (and others) in OS X is an example where it’s not clear at first that Apple is doing something wrong, but they are:
The check-mark in the middle left (marked blue) is not really a check-box, it indicates – together with grayed text – the selected option out of a radio group. That’s conventionally done with round bullet marks (although sometimes two can be activated at the same time here). The check mark above that actually is used to indicate whether a single “show” option is active. That convention could also have been used in the lower part (marked red), but Apple currently favors lengthy natural language action labels which toggle state, i.e. here “show” becomes “hide” upon activation and vice versa and “enter” becomes “exit” (or “leave”, I don’t know).