2

I hope I'm able to describe this functionality effectively.

We have a feature which allows a user to create "Authenticator Groups". The groups determines how a user can register. There are "Allowed" authenticator groups and "Disallowed" authenticators (not groups!). Allowed authenticators, for example, could contain the following:

Group 1

  • Android 5.0

  • Nexus 5

Group 2

  • iOS 8.0

  • iPhone 5S

Group 3

  • Nexus 6

So the above means that you can register with:

  1. Andoid 5.0 AND Nexus 5 OR
  2. iOS 8 AND iPhone 5S OR
  3. Nexus 6

Then there are the "Disallowed" authenticators which would be something like:

  • Android 4.0

Combining this with the allowed authenticator types would effectively rule out a Nexus 6 device running Android 4.0.

Frankly, I don't really know how to approach the UI for this feature. The aim is, obviously, to make a somewhat complex feature be as easy as possible to understand for the user. I'm hoping someone can help me out with this and I hope that the format of this question is suited to this Stack Exchange site.

  • This feature allows one user to create "Authenticator Groups" for other users? And you want to know what would be the best design for such a tool? Or did I misunderstood something? – locationunknown Feb 6 '15 at 10:44
  • @locationunknown That's exactly right – garethdn Feb 6 '15 at 10:53
1

It does sound like a tree. The most obvious form will probably look like the following (option 1):

It can be optimized a bit (option 2):

Or simplified (option 3):

Does any of these options look suitable?

0

To me seems easier to understand if you group them more

Authenticate:

  • Nexus 5 with Android 5.0
  • iPhone 5s with iOS8
  • Nexus 6 with Android 6.0

If this are the only authentication options, it is obvious that if it's not in the list, it is not allowed (i.e. Android 4.0). But if needed you could add it as a footnote.

Adding the disallowed as a footnote has the problem that perhaps they don't notice, so in that case you should have a proper error message perhaps, on the other hand, if they don't add an Android 4.0, then it worked perfectly and the user didn't even know she could've done something wrong.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.