0

I like to go look at other peoples examples of interface layouts and design patterns. The other day I went to go look at design patterns for the standard "spinner" user input...

enter image description here

...but found that a lot of my search variations pulled up another design component. This "loading" spinner image is used as a placeholder to communicate to users that a page or section is loading...

enter image description here

The problem with this is that now there is a potential confusion. I guess what is driving my question is that I also want to practice good usability in my communications with business stakeholders and team members. I don't want there to be a miscommunication due to the way I refer to this widget.

Is there a best name for the "spinner" user input that does not result in potential misinterpretation?

  • I typically refer to it as: Loading Gif – Xtian Jun 18 '14 at 15:41
  • Thanks for your input Xtian. Yah, I too usually call those round ones "loading gifs". I'm mainly concerned with the input image above the round ones that has the "57" in it. What would you call that? – eeklipzz Jun 19 '14 at 15:29
  • In MFC they are called Spin buttons. – sergiol Jul 18 '14 at 23:20
2

iOS calls this a "stepper" (usually associated with some feedback of the value)

enter image description here

A "spinner" on Android is similar to what you are referring to, though there are no increment buttons

enter image description here

And what I would call a "loading animation" is called an "Activity Circle" or "Activity Indicator" on Android & iOS respectively.

enter image description here

iOS Guidelines

Android Guidelines (Progress & Activity)

1

I never like calling that input a "spinner" unless it looped back around through the input values.

On iOS it is called a "Stepper" since you incrementally step between values. https://developer.apple.com/library/ios/documentation/uikit/reference/UIStepper_Class/Reference/Reference.html

1

I did some research while I was waiting for answers...

http://uxfindings.blogspot.com/2014/06/is-numeric-spinner-best-name-for-this.html

0

If you feel there might be confusion and need to be specific, call it a number input spinner. The other type of spinner that reassures the user that there is still content to come is called a loading spinner.

There is a similar name conflict between the range slider and image slider.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.