2

I have two linked combos, Year and Week.

Right now the starting state show Select Year as the option for Year and nothing for Week, because you havent select any Year yet

enter image description here

When you select Year the Week Combo is populated including the default option Select a Week.

enter image description here

Should the Week combo also start with Select a Week option even when you havent select any Year and cant really select a Week?

2

I think you're doing well with the examples you have posted, but I'd suggest some tiny changes.

Let the initial state be as you've shown, but with the "Select Year" changed to "Select Year First" and the Week combo blank and disabled (label greyed out too).

Once a year is selected, enable to Week combo and show the "Select Week" hint, just as in your example.

This is a slight improvement, in that it should be obvious what control you can fill in first (the hint says "Select Year First" and the other combo is disabled until you do).

|improve this answer|||||
  • What about if I leave Select Year but for Week instead of Empty List I use Select Year First? Also can make Week disable until a year is selected – Juan Carlos Oropeza Apr 19 '18 at 4:50
  • @JuanCarlosOropeza I don't think it makes sense to say "Select Year First" in the Week field. That message should be in the field it refers to, as mentioned above. Yes, as I said, disable the Week until the Year is selected. – Steve Jones Apr 19 '18 at 7:27
  • The problem is there are total 6 combo box, in pairs like the one I show here. So would be A1: First selectA1 A2: Disable -- B1: First selectB1 B2: Disable -- C1: First selectC1 C2: Disable. That is why I think the disable one should point out what need to be select to be enabled – Juan Carlos Oropeza Apr 19 '18 at 14:29
  • It is up to you, of course, but if the pairs of contols are laid out in a good way, it should be obvious that they work as a pair, so even with three pairs, it'd still work. Whitespace ± separators are good here. – Steve Jones Apr 19 '18 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.