0

I'm implementing something that uses shift-click and ctrl-click (cmd on the Mac) in the normal way. Shift-click lets you select a range of elements and ctrl-click lets you toggle the selection of single elements in the set.

I'd like a way to name the click act that is semantic and OS-agnostic, but can't find anything. Instead of having to pick CLICK+CTRL or CLICK+CMD as the value, I'd like to report CLICK+(something) that describes the action, not just names a key.

(In addition to the mouse action, I also have an action type, so I don't need to encode whether the element was selected or deselected, for example--just how the mouse and keyboard were used to cause the action.)

Anybody know a reasonably standard name or have any good suggestions? Everything I come up with seems either overly descriptive or slightly incorrect in edge cases.

My best tries are:

  • CLICK_RANGE
  • CLICK_MULTI
  • CLICK_TOGGLE

At this point, I'm tempted to just give up and use CLICK_SHIFT and CLICK_CTRL.

1
  • Assuming that Shift+click also allows you to DEselect a range of elements then CLICK_SINGLE and CLICK_MULTI seems the obvious choice but this is only even going to be opinion based Jun 6, 2018 at 14:23

1 Answer 1

-1

This functionality is often called extended selection (e.g. SelectionMode.MultiExtended in .NET]), so I'd go with something like CLICK_EXTENDED.

1
  • For SHIFT or CTRL. And what name for the other one? :-) Sep 7, 2017 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.