I work on a Java application that deals with cloud security.
We have just introduced a "Forgotten your password?" link on our login screen. Due to the nature of the product, users have to turn this feature on before the link will work.
This means that we have to document how to turn on the feature, which means that we need to name the feature.
I would prefer to tell users that they can turn on the "Forgotten your password" link. My reasoning is that in the mind of a user, the UI text defines the name of the feature.
A colleague doesn't like this, and wants to tell users that they can turn on Password Recovery. He likes this better because it looks less awkward.
Do you have evidence of which would work better for users? Alternatively, do you have a better approach?