Most of todays applications have a menu called
Help as the last element in the menu bar. But many applications are using the
Help menu as a general container for anything that does not fit into other menus rather then for help content.
A good example is the IDE eclipse:
It's easy to see that the menu contains, besides the actual help entries, multiple entries that are not associated with the topic
Check for Updates (found in many applications), and so on.
Should a menu like that not be called
More... rather than