Take the 2-minute tour ×
User Experience Stack Exchange is a question and answer site for user experience researchers and experts. It's 100% free, no registration required.

I am building a control which is a table containing other controls (text boxes and dropdown lists) where the user can add/remove rows to the table. I am unsure of what to name this control and am wondering if there is a standrad name for such a thing. Here is an (un-stylized) example:


Example


The columns in the control can very, but every row will always have the same controls for each instance of this control. In the example shown, the control is for choosing data sources and giving the sources labels. In every instance of this control, each row will have a "remove" button, and the user will be able to add new rows.

Right now my code calls this an AddRemoveTableControl, which is horrid. What is the proper name for such a control?

share|improve this question
1  
We call it an inline editor since you're adding/editing things all inline. We use this terminology when relating to any sort of control that lets you add/remove/edit multiple items at a time. –  Ben Jul 12 '12 at 19:52
    
Sorry, is this in regards to the name of the control presented in the UI or just the name of the control within the code? –  Tom R Jul 12 '12 at 20:25
    
This is the name of the control in the code @TomR –  Josh Jul 12 '12 at 20:40

3 Answers 3

up vote 2 down vote accepted

How about a "RowCollection" control?

This is an array of rows

  • we can force an additional row to the end, initialized to defaults
  • we can remove a row based on positional notation
  • So the underlying mechanic is an array of one or more columns
  • each record in the array is one row, consisting of one or more columns

So it's technically a rowcollection

share|improve this answer
1  
I love this! It fits my need very well. –  Josh Jul 12 '12 at 19:44

Microsoft Excel and Google Docs call this "Insert/Delete Row."

So, you might call it insertRow and deleteRow.

share|improve this answer
    
This is a single control, so should I call it an InsertDeleteRowControl? –  Josh Jul 12 '12 at 17:44
1  
No, this is two controls that appear together on one panel. –  jcolebrand Jul 12 '12 at 19:28
    
Yeah, sorry, I think I misunderstood the question. –  tajmo Jul 12 '12 at 20:29

It's a customization dialogue (you can call it Customize). MS Outlook has a window called Field Chooser, which seems to me like a good name.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.